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MANUAL 

 

DAFTAR ISI 

1. Menginstal program 

2. Pengenalan bagian-bagian program  

3. Room Editor 

a. Membuat ruangan baru 

b. Membuka file ruaangan 

c. Menambahkan bukaan  dinding  

d. Memilih aksi bukaan dinding 

e. Penyimpanan File 

f. Grid  

g. Database bukaan dinding 

4. Room Layout 

a. Membuka file 

b. Menambahkan perabotan  

c. Memilih aksi perabotan 

d. Memeriksa pengaturan letak barang 

e. Penyimpanan File 

f. Grid  

g. Potongan ruangan 

h. Rule (Aturan) kelayakan 

i. Database perabotan 

 

 
MENGINSTAL PROGRAM 

 

Program Room Editor & Layout.rar harus di extract ke direktori C: 

Program ini terdiri dari program Room Editor, Room Layout, Database dan Help. 

 

http://www.petra.ac.id
http://digilib.petra.ac.id/index.html
http://digilib.petra.ac.id/help.html
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PENGENALAN BAGIAN-BAGIAN PROGRAM  

 

Sebelum menggunakan program, user sebaiknya terlebih dahulu mengenali 

beberapa istilah dan sistem koordinat yang digunakan dalam program ini. 

§ Menu utama terdiri dari File, Wall Opening atau Furniture, Options dan 

Help yang beberapa diantaranya memiliki submenu. 

§ Shortcut terdiri dari Open, Save, Save as image, Grid dan lain lain. 

§ 5 tampilan ruangan : Denah, Potongan A, B, C dan D. 

§ Canvas yang menampilkan gambar ruangan. 

Petunjuk sistem koordinat: 

Koordinat (0,0) canvas berada pada kiri atas canvas.  

Posisi (0,0) ruangan berada pada sebelah dalam pertemuan tembok kiri dan 

atas. 

Sumbu x,y, dan z berganti sesuai dengan sudut pandang ruangan yang 

sedang aktif. 

§ Ruangan dibatasi oleh tembok berwarna abu-abu dengan tebal tetap yaitu 

10 cm.  

§ Panel status yang menampilkan keterangan mengenai ruangan: 

o Jenis dan ukuran ruangan 

o Skala ruangan 

Skala 1 cm/pixel berarti 1 pixel gambar ruangan mewakili 1 cm 

ruangan nyata.  

o Koordinat kursor ketika melewati canvas, dalam bentuk koordinat 

ruangan (cm) atau koordinat canvas (pixel).  

 

 
ROOM EDITOR 

Membuat Ruangan Baru 

 

Untuk membuat ruangan, dapat menggunakan perintah File->New Room pada 

menu utama atau menggunakan shortcut New. 
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Yang perlu dilakukan dalam membuat ruangan baru adalah: 

§ Memilih jenis ruangan 

§ Memasukkan ukuran (panjang, lebar dan tinggi) ruangan sesuai dengan 

batas ukuran yang ada.  

 

 
Membuka File Ruangan 

 

Untuk membuka file Room Editor (bertipe .edt), dapat menggunakan perintah 

File->Open atau menggunakan shortcut Open. Perintah ini digunakan untuk 

membuka file yang sudah ada atau sudah disimpan sebelumnya. 

 
Menambahkan Bukaan Dinding 

 

Untuk menambahkan bukaan dinding ke dalam Room Editor, gunakan perintah 

Wall Opening -> Add... atau shortcut Add wall opening object. 

Yang perlu dilakukan dalam menambahkan bukaan dinding: 

§ Memilih jenis bukaan dinding 

§ Memilih nama bukaan dinding 

§ Memperhatikan detail bukaan dinding (lihat keterangan di bawah), apakah 

sesuai dengan bukaan dinding yang diinginkan? 

§ Memilih 2 metode penambahan bukaan dinding  

o Add  

Pilihan ini dipakai jika user tidak mengetahui koordinat pasti untuk 

peletakan bukaan dinding. Gambar bukaan dinding akan ditampilkan 

di posisi yang ditunjukkan kursor, dan terus berpindah mengikuti 

perubahan posisi kursor. Jika user menemukan posisi yang pasti, maka 

proses Add diakhiri dengan meng-klik tombol kiri mouse. 

o Add to  

Sebaiknya digunakan jika user mengetahui dengan pasti posisi atau 

koordinat dimana bukaan dinding ingin diletakkan.  
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Yang perlu diperhatikan dalam Add to:  

- Memilih dinding tempat bukaan dinding hendak diletakkan 

- Memilih sistem koordinat (pixel atau cm) 

- Memasukkan koordinat x/y dan z 

- Option 'Use z default' jika diaktifkan, maka koordinat z 

(ketinggian benda) tidak perlu diisi, melainkan menggunakan hasil 

perhitungan program. 

- Option 'Snap to wall’ jika diaktifkan, maka akan melakukan 

pengecekan terhadap koordinat yang dimasukkan. Jika koordinat 

tersebut mengakibatkan benda melewati batas ruangan, maka 

koordinat tersebut akan dikoreksi untuk menghasilkan koordinat 

yang sesuai. 

-  

Detil Bukaan dinding 

Detil bukaan dinding yang lengkap terdiri dari: 

§ Nama bukaan dinding  

§ Jenis bukaan dinding  

§ Titel bukaan dinding  

§ Ukuran bukaan dinding: lebar dan tinggi  

§ Gambar bukaan dinding: denah dan tampak depan  

§ Keterangan  

§ Posisi bukaan dinding (x,y,z) 

§ Dinding tempat bukaan dinding diletakkan.  

 

Tidak semua form menggunakan detil yang lengkap, tetapi hanya menampilkan 

detil bukaan dinding yang dianggap perlu. 

 

 
Memilih Aksi Bukaan Dinding 

 

Untuk melakukan aksi terhadap suatu bukaan dinding gunakan perintah Wall 

Opening->Actions ... atau shortcut Wall opening action. 
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Yang perlu dilakukan: 

§ Memilih Titel bukaan dinding 

§ Memperhatikan detail bukaan dinding, sesuai dengan bukaan dinding yang 

diinginkan? 

§ Memilih aksi yang ingin dilakukan:  

o Move : memindahkan bukaan dinding ke posisi baru mengikuti 

pergerakan kursor mouse.  

o Move To : memindahkan bukaan dinding ke koordinat/posisi tertentu 

(lihat Add To). 

o Delete : menghapus bukaan dinding dari ruangan 

o Flip Horizontal : membalikkan bukaan dinding secara horisontal  

o Flip Vertical : membalikkan bukaan dinding secara vertikal 

 

 
Penyimpanan File 

 

Untuk menyimpan rancangan ruangan sebagai file Room Editor gunakan menu 

File->Save. Untuk menyimpannya sebagai file bitmap gunakan menu File->Save 

as image. 

 

 
Grid 

 

Untuk menampilkan atau menghilangkan garis bantu atau Grid, gunakan perintah 

Options->Grid->Show. 

Untuk mengubah atribut grid, gunakan perintah Options->Grid->Properties.... 

Atribut grid antara lain: 

§ Ukuran (dalam cm/pixel) 

§ Warna  

§ Style  
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Database Bukaan dinding 

 

Gunakan perintah Options->Database... untuk mengakses master data bukaan 

dinding di database. Perlu diketahui, perubahan yang dilakukan terhadap 

database, berpengaruh terhadap file Room Editor. Karena itu gunakanlah fasilitas 

ini dengan bijaksana. 

 

Read Me  

Berisi hal-hal yang perlu diketahui dalam menggunakan fasilitas database 

(Silakan dibaca!) 

 

Add - Menambahkan bukaan dinding ke dalam database 

Yang perlu dilakukan:  

§ Memilih jenis bukaan dinding (nama bukaan dinding akan di generate 

otomatis). 

§ Memasukkan ukuran bukaan dinding (lebar dan tinggi) 

§ Meng-klik Browse untuk menunjukkan file-file gambar bukaan dinding 

§ Memilih ketinggian bukaan dinding sesuai situasi yang digambarkan, atau 

dengan memasukkan sendiri ketinggian yang diinginkan. 

§ Memberikan keterangan singkat mengenai bukaan dinding. 

§ Klik tombol Add untuk menambahkan bukaan dinding baru, atau Cancel 

untuk membatalkan. 

 

Edit - Mengubah data bukaan dinding 

Yang perlu dilakukan:  

§ Memilih jenis bukaan dinding 

§ Memilih nama bukaan dinding 

§ Mengubah ukuran bukaan dinding 

§ Meng-klik Browse untuk menunjukkan file-file gambar bukaan dinding 

§ Mengubah ketinggian bukaan dinding 

§ Megubah keterangan singkat mengenai bukaan dinding 
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§ Klik tombol Edit untuk mengubah data bukaan dinding, atau Cancel untuk 

membatalkan. 

 

Delete – Menghapus bukaan dinding 

Bukaan dinding yang dapat dihapus adalah bukaan dinding yang belum pernah 

digunakan,  

Yang perlu dilakukan: 

§ Memilih jenis bukaan dinding 

§ Memilih nama bukaan dinding 

§ Klik Delete untuk menghapus bukaan dinding atau Cancel untuk 

membatalkan. 

 

 
ROOM LAYOUT 

Membuka File 

 

Untuk membuka file Room Editor gunakan menu File->Open Room atau 

shortcut Open .edt file. 

Untuk membuka file Room Layout gunakan menu File->Open Layout atau 

shortcut Open .lyt file. 

 

 
Menambahkan Perabotan 

 

Untuk menambah bukaan dinding perabotan ke dalam canvas ruanga, gunakan 

menu Furniture->Add Furniture ... atau  shortcut Add furniture . 

Yang perlu dilakukan: 

§ Memilih jenis perabotan 

§ Memilih nama perabotan 

§ Memperhatikan detail perabotan (lihat keterangan di bawah), apakah 

sesuai dengan perabotan yang diinginkan? 

§ Memilih 2 metode penambahan perabotan  
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o Add  

Pilihan ini dipakai jika user tidak mengetahui koordinat pasti untuk 

peletakan perabotan. Gambar perabotan akan ditampilkan di posisi 

yang ditunjukkan kursor, dan terus berpindah mengikuti perubahan 

posisi kursor. Jika user menemukan posisi yang pasti, maka proses 

Add diakhiri dengan meng-klik tombol kiri mouse. 

o Add to  

Sebaiknya digunakan jika user mengetahui dengan pasti posisi atau 

koordinat dimana bukaan dinding ingin diletakkan.  

Yang perlu diperhatikan dalam Add to:  

- Memilih dinding tempat perabotan hendak diletakkan untuk obyek 

On-Wall atau memilih besar rotasi untuk obyek yang bukan obyek 

On-Wall 

- Memilih sistem koordinat (pixel atau cm) 

- Memasukkan koordinat x,y dan z 

- Option 'Snap to wall if excedd room’ jika diaktifkan, maka akan 

melakukan pengecekan terhadap koordinat yang dimasukkan. Jika 

koordinat tersebut mengakibatkan benda melewati batas ruangan, 

maka koordinat tersebut akan dikoreksi untuk menghasilkan 

koordinat yang sesuai. 

 

Detil Perabotan  

Detil perabotan yang lengkap terdiri dari: 

§ Nama perabotan  

§ Jenis perabotan 

§ Titel perabotan 

§ Ukuran: panjang, lebar dan tinggi  

§ Keterangan  

§ Sifat penempatan perabotan: On-Floor, On-Surfaces, On-Wall 

§ Clearance: Atas, Bawah, Depan, Belakang, kiri dan Kanan perabotan 

§ Gambar perabotan: denah, tampak depan, tampak belakang, tampak kiri 

dan kanan.  
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§ Posisi perabotan (x,y,z) 

§ Ruangan yang sesuai untuk peletakan perabotan. 

 

Tidak semua form menggunakan detil yang lengkap, tetapi hanya menampilkan 

detil bukaan dinding yang dianggap perlu. 

 

 
Memilih Aksi Perabotan 

 

Untuk melakukan aksi terhadap perabotan yang sudah dimasukkan ke dalam 

ruangan, gunakan perintah Furniture->Furniture Actions ... atau shortcut 

Furniture action. 

Yang perlu dilakukan: 

§ Memilih Titel perabotan 

§ Memilih aksi yang ingin dilakukan:  

o Move : memindahkan perabotan ke posisi baru mengikuti pergerakan 

kursor mouse.  

o Move To : memindahkan perabotan ke koordinat/posisi tertentu (lihat 

Add To). 

o Rotate : memutar perabotan sebesar 00, 900, 1800 atau 2700 searah 

jarum jam. 

o Delete : menghapus perabotan dari ruangan 

 

 
Memeriksa Pengaturan Letak Perabotan 

 

Setelah memasukkan perabotan ke dalam rancangan ruangan dan mengaturnya, 

user dapat memeriksa apakah pengaturan tersebut melanggar aturan kelayakan. 

Untuk memeriksanya gunakan menu Furniture -> Check Furniture 

Arrangement atau shortcut Check Furniture Arrangemen. 
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Penyimpanan File 

 

Untuk menyimpan rancangan ruangan sebagai file Room Layout gunakan menu 

File->Save. Untuk menyimpannya sebagai file bitmap gunakan menu File->Save 

as image. 

 

 
Grid 

 

Untuk menampilkan atau menghilangkan garis bantu atau Grid, gunakan perintah 

Options->Grid->Show. 

Untuk mengubah atribut grid, gunakan perintah Options->Grid->Properties.... 

Atribut grid antara lain: 

§ Ukuran (dalam cm/pixel) 

§ Warna  

§ Style  

 

 
Potongan Ruangan 

 

Ukuran potongan ruangan tampilan ruangan yang ditampilkan pada Section A, B, 

C dan D. Nilai awal ukuran potongan ruang adalah 0 dan untuk menggantinya 

gunakan menu Options->Room Section. 

 

 
Rule (Aturan) Kelayakan  

 

Setiap kali terjadi perubahan posisi perabotan,  program akan melakukan 

pemeriksaan aturan dasar dan aturan kelayakan pengatuan perabotan. Sejak awal, 

Aturan kelayakan sudah aktif dan untuk menonaktifkannya dapat menggunakan 

menu Options->Activate Rule of Proper Positioning. 



 

Room Editor & Layout Manual 
 

 

 
Database Perabotan 

 

Gunakan perintah Options->Database... untuk mengakses master data perabotan 

di database. Perlu diketahui, perubahan yang dilakukan terhadap database, 

berpengaruh terhadap file Room Layout. Karena itu gunakanlah fasilitas ini 

dengan bijaksana. 

 

Read Me  

Berisi hal-hal yang perlu diketahui dalam menggunakan fasilitas database 

(Silakan dibaca!) 

 

Add - Menambahkan perabotan ke dalam database 

Yang perlu dilakukan:  

§ Memilih jenis perabotan (nama perabotan akan di generate otomatis). 

§ Memasukkan ukuran perabotan (panjang, lebar dan tinggi) 

§ Meng-klik Browse untuk menunjukkan file-file gambar perabotan 

§ Memilih sifat peletakan perabotan. 

§ Memasukkan clearance perabotan 

§ Memberikan keterangan singkat mengenai perabotan. 

§ Memilih ruangan yang sesuai untuk peletakan perabotan 

§ Klik tombol Add untuk menambahkan perabotan baru, atau Cancel untuk 

membatalkan. 

 

Edit - Mengubah data perabotan 

Yang perlu dilakukan:  

§ Memilih jenis perabotan  

§ Memilih nama perabotan 

§ Mengubah ukuran perabotan (panjang, lebar dan tinggi) 

§ Meng-klik Browse untuk menunjukkan file-file gambar perabotan 

§ Memilih sifat peletakan perabotan. 
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§ Mengubah clearance perabotan 

§ Mengubah keterangan singkat mengenai perabotan. 

§ Memilih ruangan yang sesuai untuk peletakan perabotan 

§ Klik tombol Edit untuk mengubah data perabotan, atau Cancel untuk 

membatalkan. 

 

Delete – Menghapus perabotan 

Perabotan yang dapat dihapus adalah perabotan yang belum pernah digunakan,  

Yang perlu dilakukan: 

§ Memilih jenis perabotan 

§ Memilih nama perabotan 

§ Klik Delete untuk menghapus perabotan atau Cancel untuk membatalkan. 
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